sunk my brand new 2015 WDK rip...she gone

Joined
Mar 27, 2012
Likes
43
Location
Lake Hogan
#1
sunk the brand new rip in the delta and now Progressive insurance wont honor there insurance because they said they sent a letter 2 days before my ski sunk saying it was too much liabilty....BS i never got the letter so now im out of a ski.. thanks progressive beware !!!
 

INDebtSJ

Having a VISION!
Joined
May 7, 2006
Likes
422
Location
Ga
#4
OMG.
I just cringe when I see stories like this! I hope you get it straightened out with the insurance company. I would talk to a lawyer too. Its cheaper than buying a new ski.

Now I am going to have to figure out how to foam the vision. My lake is over 100ft deep.
 
Joined
Mar 27, 2012
Likes
43
Location
Lake Hogan
#5
its currently 30-40 deep right now 0 viz ive had a diver out twice and a good group of friends trying to help me but its in a shipping channel and with no way to tell the divers ships are coming its kinda sketch... plus 10mph current at the bottom was giving the diver a hard time
 

Roseand

Ready to RIP
Site Supporter
Joined
Dec 31, 2012
Likes
2,104
Location
Wisconsin
#8
Anddddd thats why I have a retriever and stuffed every cavity with pool noodles.. Thats terrible man, sorry to hear that..

Sent from my SM-G920V using Tapatalk
 
Joined
Aug 25, 2014
Likes
62
Location
Illinois
#14
Water probably displaced the air inside the hull. ;) sorry for your loss I would be sick if I lost my ski.
I understand that part... curious if was an exhaust failure...pump issue...hood issue...crack... or a mystery?

I have the same hull, and plan to stuff area under the tray with a couple lifejackets or something.
 
Joined
Nov 28, 2011
Likes
607
Location
Linden, CA
#19
It was an exhaust hose failure. Assuming clamp issue. It really blows because this had to be the only ski with a 701 I think I could have laid a combo on, I really do miss it. I will have a retriever on mine you can count on that

Sent from my SCH-I545 using Tapatalk
 
Joined
Aug 25, 2014
Likes
62
Location
Illinois
#20
It was an exhaust hose failure. Assuming clamp issue. It really blows because this had to be the only ski with a 701 I think I could have laid a combo on, I really do miss it. I will have a retriever on mine you can count on that

Sent from my SCH-I545 using Tapatalk
What a bummer. I hope you guys find it!
 
Top Bottom