Weird Msd TL problem

Joined
Jan 24, 2012
Likes
133
Location
Finland
#1
So i have had msd TL many years so i know lots about it but now im confused..

Problem is that when start my jetski it works perfectly i can do it 5-10 times but then no spark.. when i disconnect brainbox power and turn it on and start no problems it will start instantly. Then after few starts again no spark..

Its new build and msd did work perfectly when it was in rickter..
But now this..

Ground wires are new. Ingnition coils are grounded to battery and engine. Picup plate is how it supposed to be..

Any ideas where to start solving this

Thanks
 

Christian_83

Xscream
Site Supporter
Joined
Feb 4, 2006
Likes
987
Location
Denmark
#4
i would try and take everything apart. Mount on a plate on a bench setup, go every wire through. Check that all grounds are there, the coils are grounded the right places.
If this dosent work, i guess the could be toasted.
Was it a new or used brain?
 
Joined
Jan 24, 2012
Likes
133
Location
Finland
#5
Brain is old but id did work in last ski.

Coils are grounded right

I just noticed that when box goes no spark mode that led is still blinking so box has power and it is working

Yesterday i start it over 30 times until no spark. Last time that i start it and shut it down i figure out that it goes to no spark only when engine stops not correctly (normal full stop) but more like stops and it sounds like small backfire and engine spins half round to wrong direction. After that no spark. But when engine stops correctly then no problem

Engine is brand new (10hours) oem superjet 701 with blowsion head.
 

Christian_83

Xscream
Site Supporter
Joined
Feb 4, 2006
Likes
987
Location
Denmark
#6
I think you need to try a new brain. If all connections are good, you got 12V+, the LED is till blinking after "no fire" AND you can still no trigger ignition with short circuit the pickup wires.
 
Joined
May 30, 2006
Likes
89
#7
I'd tend to agree with Christian on the brain going. The backfire you get just before loosing spark is likely caused by it failing.

Certainly worth going through every wire and connection as suggested to rule that out, brains aren't cheap so worth a good check first.
 
Joined
Jan 24, 2012
Likes
133
Location
Finland
#8
I have 2 brainbox in my garage so i can test it. Not easy to do because if it is wire that is broken there is a possibility that by moving all those wires it might self fix atleast for a moment.

Weird part is that no spark comes only if i push stop button.. not while running.. i think i go to lake to see if it does shut down when riding or is it releated to stop button..

i have never heard that msd box works only half. Usually you loose channel or two but nothing like this.. basic rule has been that if led is working so is your box.. well expect one time when i had broken led
 

Christian_83

Xscream
Site Supporter
Joined
Feb 4, 2006
Likes
987
Location
Denmark
#9
No its electronics, so everything can go bad. But most common is a channel dying.
BUT i understood from you, that you double checked and wiring was no issue?
I would still take your setup and take it all apart. mount it on a alu/stainless plate and wire everything up again. Then ride with it and see if problem is still there.
If this dosent work, try another brain.
I donno if the START/STOp assembly can be bad, with bad connection, making this problem. Maybe try going "around" the START/STOP assembly
 
Joined
Jan 24, 2012
Likes
133
Location
Finland
#10
Good idea ill do that start stop test.
Why metal plate? Now i have plastic plate. Same material that you use in atv bottom armory.. i have one bolt thru that plate and box is grounded there from that bolt there is ground wire to battery and to engine. Coils are grounded there too.. i dont see why it would be a problem?

No i have not check my wirings exept ground wires i did renew them. But i will check them.

It just not making any sense that when i disconnect/connect deutch connector that feeds power to brain and that solves everything.. if that connector is bad then there should not be led blinking
 
Top Bottom